re = /^\s*\x60(\w*)\x60\s*(.*?)(?:COMMENT \'(.*)\')?,$/m
str = ' `wallet_number` varchar(15) NOT NULL,
`created_by` bigint(20) DEFAULT NULL,
`updated_by` bigint(20) DEFAULT NULL,
`deleted_by` bigint(20) DEFAULT NULL COMMENT \'Due date of task\',
`status` int(11) NOT NULL,
`comment` longtext,
`createdAt` datetime DEFAULT NULL,
`updatedAt` datetime DEFAULT NULL,
PRIMARY KEY (`wallet_number`)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end