import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\x60(\\w*)\\x60\\s*(.*?)(?:COMMENT \\'(.*)\\')?,$";
final String string = " `wallet_number` varchar(15) NOT NULL,\n"
+ " `created_by` bigint(20) DEFAULT NULL,\n"
+ " `updated_by` bigint(20) DEFAULT NULL,\n"
+ " `deleted_by` bigint(20) DEFAULT NULL COMMENT 'Due date of task',\n"
+ " `status` int(11) NOT NULL,\n"
+ " `comment` longtext,\n"
+ " `createdAt` datetime DEFAULT NULL,\n"
+ " `updatedAt` datetime DEFAULT NULL,\n"
+ " PRIMARY KEY (`wallet_number`)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}