using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*\x60(\w*)\x60\s*(.*?)(?:COMMENT \'(.*)\')?,$";
string input = @" `wallet_number` varchar(15) NOT NULL,
`created_by` bigint(20) DEFAULT NULL,
`updated_by` bigint(20) DEFAULT NULL,
`deleted_by` bigint(20) DEFAULT NULL COMMENT 'Due date of task',
`status` int(11) NOT NULL,
`comment` longtext,
`createdAt` datetime DEFAULT NULL,
`updatedAt` datetime DEFAULT NULL,
PRIMARY KEY (`wallet_number`)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}