package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*\x60(\w*)\x60\s*(.*?)(?:COMMENT \'(.*)\')?,$`)
var str = ` \`wallet_number\` varchar(15) NOT NULL,
\`created_by\` bigint(20) DEFAULT NULL,
\`updated_by\` bigint(20) DEFAULT NULL,
\`deleted_by\` bigint(20) DEFAULT NULL COMMENT 'Due date of task',
\`status\` int(11) NOT NULL,
\`comment\` longtext,
\`createdAt\` datetime DEFAULT NULL,
\`updatedAt\` datetime DEFAULT NULL,
PRIMARY KEY (\`wallet_number\`)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}