re = /(?<year>\d{4})(?<month>\d{1,2})(?<day>\d{1,2})/m
str = '19911231'
subst = '${year}-${month}-${day}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result