const regex = /(?<year>\d{4})(?<month>\d{1,2})(?<day>\d{1,2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<year>\\d{4})(?<month>\\d{1,2})(?<day>\\d{1,2})', 'gm')
const str = `19911231`;
const subst = `${year}-${month}-${day}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);