package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<year>\d{4})(?<month>\d{1,2})(?<day>\d{1,2})`)
var str = `19911231`
var substitution = "${year}-${month}-${day}"
fmt.Println(re.ReplaceAllString(str, substitution))
}