# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<year>\d{4})(?<month>\d{1,2})(?<day>\d{1,2})/${year}-${month}-${day}/gm;t' <<< "19911231"