$re = '/(?<year>\d{4})(?<month>\d{1,2})(?<day>\d{1,2})/m';
$str = '19911231';
$subst = "${year}-${month}-${day}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;