import Foundation
let pattern = ##"(?<=watch\?v=|/videos/|embed\/|youtu.be\/|\/v\/|\/e\/|watch\?v%3D|watch\?feature=player_embedded&v=|%2Fvideos%2F|embed%2F|youtu.be%2F|%2Fv%2F|shorts\/|live\/)[^#\&\?\n]*"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.youtube.com/watch?v=dmBbyHx_QKU
https://www.youtube.com/live/dmBbyHx_QKU?si=3f5yaTBKl0ZW8Kyg
https://www.youtube.com/embed/dmBbyHx_QKU?si=3f5yaTBKl0ZW8Kyg
https://www.youtube.com/shorts/Wpzu--so_ts
https://youtube.com/shorts/Wpzu--so_ts?si=xVSHgPWtOS2uyR9K
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)