using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=watch\?v=|/videos/|embed\/|youtu.be\/|\/v\/|\/e\/|watch\?v%3D|watch\?feature=player_embedded&v=|%2Fvideos%2F|embed%2F|youtu.be%2F|%2Fv%2F|shorts\/|live\/)[^#\&\?\n]*";
string input = @"https://www.youtube.com/watch?v=dmBbyHx_QKU
https://www.youtube.com/live/dmBbyHx_QKU?si=3f5yaTBKl0ZW8Kyg
https://www.youtube.com/embed/dmBbyHx_QKU?si=3f5yaTBKl0ZW8Kyg
https://www.youtube.com/shorts/Wpzu--so_ts
https://youtube.com/shorts/Wpzu--so_ts?si=xVSHgPWtOS2uyR9K";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}