use strict;
my $str = 'https://www.youtube.com/watch?v=dmBbyHx_QKU
https://www.youtube.com/live/dmBbyHx_QKU?si=3f5yaTBKl0ZW8Kyg
https://www.youtube.com/embed/dmBbyHx_QKU?si=3f5yaTBKl0ZW8Kyg
https://www.youtube.com/shorts/Wpzu--so_ts
https://youtube.com/shorts/Wpzu--so_ts?si=xVSHgPWtOS2uyR9K';
my $regex = qr/(?<=watch\?v=|/videos/|embed\/|youtu.be\/|\/v\/|\/e\/|watch\?v%3D|watch\?feature=player_embedded&v=|%2Fvideos%2F|embed%2F|youtu.be%2F|%2Fv%2F|shorts\/|live\/)[^#\&\?\n]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}