import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=watch\\?v=|/videos/|embed\\/|youtu.be\\/|\\/v\\/|\\/e\\/|watch\\?v%3D|watch\\?feature=player_embedded&v=|%2Fvideos%2F|embed%2F|youtu.be%2F|%2Fv%2F|shorts\\/|live\\/)[^#\\&\\?\\n]*";
final String string = "https://www.youtube.com/watch?v=dmBbyHx_QKU\n"
+ "https://www.youtube.com/live/dmBbyHx_QKU?si=3f5yaTBKl0ZW8Kyg\n"
+ "https://www.youtube.com/embed/dmBbyHx_QKU?si=3f5yaTBKl0ZW8Kyg\n"
+ "https://www.youtube.com/shorts/Wpzu--so_ts\n"
+ "https://youtube.com/shorts/Wpzu--so_ts?si=xVSHgPWtOS2uyR9K";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}