$re = '/(?<=watch\?v=|/videos/|embed\/|youtu.be\/|\/v\/|\/e\/|watch\?v%3D|watch\?feature=player_embedded&v=|%2Fvideos%2F|embed%2F|youtu.be%2F|%2Fv%2F|shorts\/|live\/)[^#\&\?\n]*/m';
$str = 'https://www.youtube.com/watch?v=dmBbyHx_QKU
https://www.youtube.com/live/dmBbyHx_QKU?si=3f5yaTBKl0ZW8Kyg
https://www.youtube.com/embed/dmBbyHx_QKU?si=3f5yaTBKl0ZW8Kyg
https://www.youtube.com/shorts/Wpzu--so_ts
https://youtube.com/shorts/Wpzu--so_ts?si=xVSHgPWtOS2uyR9K';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);