import Foundation
let pattern = #"^(mm[gvis]([0-9]{1,3})?|((media(\.|-)[a-zA-Z]{1,4}[0-9]{1,2}-[0-9]{1,2}\.)(cdn|fna)))\.whatsapp\.net$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
mms241.whatsapp.net
mmi362.whatsapp.net
mmv785.whatsapp.net
mmg362.whatsapp.net
mmg.whatsapp.net
media.fada1-1.fna.whatsapp.net
media.faq12-1.fna.whatsapp.net
media.saq1-13.fna.whatsapp.net
media.sif1-2.cdn.whatsapp.net
media.scf21-2.cdn.whatsapp.net
media.sqf1-25.cdn.whatsapp.net
media-scf21-2.cdn.whatsapp.net
media-sqf1-25.cdn.whatsapp.net
media-fawq1-13.fna.whatsapp.net
media.fyei6-5.fna.whatsapp.net
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)