const regex = /^(mm[gvis]([0-9]{1,3})?|((media(\.|-)[a-zA-Z]{1,4}[0-9]{1,2}-[0-9]{1,2}\.)(cdn|fna)))\.whatsapp\.net$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(mm[gvis]([0-9]{1,3})?|((media(\\.|-)[a-zA-Z]{1,4}[0-9]{1,2}-[0-9]{1,2}\\.)(cdn|fna)))\\.whatsapp\\.net$', 'gm')
const str = `mms241.whatsapp.net
mmi362.whatsapp.net
mmv785.whatsapp.net
mmg362.whatsapp.net
mmg.whatsapp.net
media.fada1-1.fna.whatsapp.net
media.faq12-1.fna.whatsapp.net
media.saq1-13.fna.whatsapp.net
media.sif1-2.cdn.whatsapp.net
media.scf21-2.cdn.whatsapp.net
media.sqf1-25.cdn.whatsapp.net
media-scf21-2.cdn.whatsapp.net
media-sqf1-25.cdn.whatsapp.net
media-fawq1-13.fna.whatsapp.net
media.fyei6-5.fna.whatsapp.net`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}