re = /^(mm[gvis]([0-9]{1,3})?|((media(\.|-)[a-zA-Z]{1,4}[0-9]{1,2}-[0-9]{1,2}\.)(cdn|fna)))\.whatsapp\.net$/m
str = 'mms241.whatsapp.net
mmi362.whatsapp.net
mmv785.whatsapp.net
mmg362.whatsapp.net
mmg.whatsapp.net
media.fada1-1.fna.whatsapp.net
media.faq12-1.fna.whatsapp.net
media.saq1-13.fna.whatsapp.net
media.sif1-2.cdn.whatsapp.net
media.scf21-2.cdn.whatsapp.net
media.sqf1-25.cdn.whatsapp.net
media-scf21-2.cdn.whatsapp.net
media-sqf1-25.cdn.whatsapp.net
media-fawq1-13.fna.whatsapp.net
media.fyei6-5.fna.whatsapp.net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end