// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(mm[gvis]([0-9]{1,3})?|((media(\.|-)[a-zA-Z]{1,4}[0-9]{1,2}-[0-9]{1,2}\.)(cdn|fna)))\.whatsapp\.net$").unwrap();
let string = "mms241.whatsapp.net
mmi362.whatsapp.net
mmv785.whatsapp.net
mmg362.whatsapp.net
mmg.whatsapp.net
media.fada1-1.fna.whatsapp.net
media.faq12-1.fna.whatsapp.net
media.saq1-13.fna.whatsapp.net
media.sif1-2.cdn.whatsapp.net
media.scf21-2.cdn.whatsapp.net
media.sqf1-25.cdn.whatsapp.net
media-scf21-2.cdn.whatsapp.net
media-sqf1-25.cdn.whatsapp.net
media-fawq1-13.fna.whatsapp.net
media.fyei6-5.fna.whatsapp.net";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}