import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(mm[gvis]([0-9]{1,3})?|((media(\\.|-)[a-zA-Z]{1,4}[0-9]{1,2}-[0-9]{1,2}\\.)(cdn|fna)))\\.whatsapp\\.net$";
final String string = "mms241.whatsapp.net\n"
+ "mmi362.whatsapp.net\n"
+ "mmv785.whatsapp.net\n"
+ "mmg362.whatsapp.net\n"
+ "mmg.whatsapp.net\n"
+ "media.fada1-1.fna.whatsapp.net\n"
+ "media.faq12-1.fna.whatsapp.net\n"
+ "media.saq1-13.fna.whatsapp.net\n"
+ "media.sif1-2.cdn.whatsapp.net\n"
+ "media.scf21-2.cdn.whatsapp.net\n"
+ "media.sqf1-25.cdn.whatsapp.net\n"
+ "media-scf21-2.cdn.whatsapp.net\n"
+ "media-sqf1-25.cdn.whatsapp.net\n"
+ "media-fawq1-13.fna.whatsapp.net\n"
+ "media.fyei6-5.fna.whatsapp.net";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}