import Foundation
let pattern = #"^[A-Z]+(?:-[A-Z]+)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
PASS :
NOR
REGISTER
FLIP-FLOP
CPU
FLIP-FLOP-FLAP
A
A-A
ALL-GOOD
TIP-US-PLEASE
OR-IS-THERE-NO-WAY-TO-GET-STUDENT-RECOGNITION-FOR-DOMAINS
FAIL :
NO-TRAILING-DASH-
-ACTUALLY-NEITHER-WAY
NO-DIGIT-TEST1
2NO-DIGIT-TEST
N0-DIGIT-T3ST
NO-SPACE
NO-SPE_CIAL-CHAR
SURE?YES
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)