import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]+(?:-[A-Z]+)*$";
final String string = "PASS :\n"
+ "NOR\n"
+ "REGISTER\n"
+ "FLIP-FLOP\n"
+ "CPU\n"
+ "FLIP-FLOP-FLAP\n"
+ "A\n"
+ "A-A\n"
+ "ALL-GOOD\n"
+ "TIP-US-PLEASE\n"
+ "OR-IS-THERE-NO-WAY-TO-GET-STUDENT-RECOGNITION-FOR-DOMAINS\n\n"
+ "FAIL :\n"
+ "NO-TRAILING-DASH-\n"
+ "-ACTUALLY-NEITHER-WAY\n"
+ "NO-DIGIT-TEST1\n"
+ "2NO-DIGIT-TEST\n"
+ "N0-DIGIT-T3ST\n"
+ "NO-SPACE \n"
+ "NO-SPE_CIAL-CHAR\n"
+ "SURE?YES";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}