// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z]+(?:-[A-Z]+)*$").unwrap();
let string = "PASS :
NOR
REGISTER
FLIP-FLOP
CPU
FLIP-FLOP-FLAP
A
A-A
ALL-GOOD
TIP-US-PLEASE
OR-IS-THERE-NO-WAY-TO-GET-STUDENT-RECOGNITION-FOR-DOMAINS
FAIL :
NO-TRAILING-DASH-
-ACTUALLY-NEITHER-WAY
NO-DIGIT-TEST1
2NO-DIGIT-TEST
N0-DIGIT-T3ST
NO-SPACE
NO-SPE_CIAL-CHAR
SURE?YES";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}