re = /^[A-Z]+(?:-[A-Z]+)*$/m
str = 'PASS :
NOR
REGISTER
FLIP-FLOP
CPU
FLIP-FLOP-FLAP
A
A-A
ALL-GOOD
TIP-US-PLEASE
OR-IS-THERE-NO-WAY-TO-GET-STUDENT-RECOGNITION-FOR-DOMAINS
FAIL :
NO-TRAILING-DASH-
-ACTUALLY-NEITHER-WAY
NO-DIGIT-TEST1
2NO-DIGIT-TEST
N0-DIGIT-T3ST
NO-SPACE
NO-SPE_CIAL-CHAR
SURE?YES'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end