using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]+(?:-[A-Z]+)*$";
string input = @"PASS :
NOR
REGISTER
FLIP-FLOP
CPU
FLIP-FLOP-FLAP
A
A-A
ALL-GOOD
TIP-US-PLEASE
OR-IS-THERE-NO-WAY-TO-GET-STUDENT-RECOGNITION-FOR-DOMAINS
FAIL :
NO-TRAILING-DASH-
-ACTUALLY-NEITHER-WAY
NO-DIGIT-TEST1
2NO-DIGIT-TEST
N0-DIGIT-T3ST
NO-SPACE
NO-SPE_CIAL-CHAR
SURE?YES";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}