import Foundation
let pattern = #"(?<fileName>.+).part[a-z]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.parta
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partb
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partc
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.parte
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)