package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<fileName>.+).part[a-z]`)
var str = `influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.parta
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partb
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partc
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.parte
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partz
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}