import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<fileName>.+).part[a-z]";
final String string = "influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.parta\n"
+ "influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partb\n"
+ "influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partc\n"
+ "influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.parte\n"
+ "influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partz\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}