// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<fileName>.+).part[a-z]").unwrap();
let string = "influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.parta
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partb
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partc
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.parte
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partz
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}