$re = '/(?<fileName>.+).part[a-z]/m';
$str = 'influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.parta
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partb
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partc
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.parte
influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partz
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);