import Foundation
let pattern = #"^\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([.]\w+)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
barney@example.de
barney.rubble@example.com
barney-rubble@example.coop
barney+rubble@example.com
barney'rubble@example.com
b.arne.y_r.ubbl.e@example.com
barney4rubble@example.com
barney4rubble!@example.com
_barney+rubble@example.com
"barney+rubble"@example.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)