re = /^\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([.]\w+)*$/mi
str = 'barney@example.de
barney.rubble@example.com
barney-rubble@example.coop
barney+rubble@example.com
barney\'rubble@example.com
b.arne.y_r.ubbl.e@example.com
barney4rubble@example.com
barney4rubble!@example.com
_barney+rubble@example.com
"barney+rubble"@example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end