#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([.]\w+)*$"
Local $sString = "barney@example.de" & @CRLF & _
"barney.rubble@example.com" & @CRLF & _
"barney-rubble@example.coop" & @CRLF & _
"barney+rubble@example.com" & @CRLF & _
"barney'rubble@example.com" & @CRLF & _
"b.arne.y_r.ubbl.e@example.com" & @CRLF & _
"barney4rubble@example.com" & @CRLF & _
"barney4rubble!@example.com" & @CRLF & _
"_barney+rubble@example.com" & @CRLF & _
""barney+rubble"@example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")