package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([.]\w+)*$`)
var str = `barney@example.de
barney.rubble@example.com
barney-rubble@example.coop
barney+rubble@example.com
barney'rubble@example.com
b.arne.y_r.ubbl.e@example.com
barney4rubble@example.com
barney4rubble!@example.com
_barney+rubble@example.com
"barney+rubble"@example.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}