import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+([-+.']\\w+)*@\\w+([-.]\\w+)*\\.\\w+([.]\\w+)*$";
final String string = "barney@example.de\n"
+ "barney.rubble@example.com\n"
+ "barney-rubble@example.coop\n"
+ "barney+rubble@example.com\n"
+ "barney'rubble@example.com\n"
+ "b.arne.y_r.ubbl.e@example.com\n"
+ "barney4rubble@example.com\n"
+ "barney4rubble!@example.com\n"
+ "_barney+rubble@example.com\n"
+ "\"barney+rubble\"@example.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}