import Foundation
let pattern = #"\/(?<directory_name>(?<template_name>[\w]+)[-\w]+)\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/materio-vuetify-vuejs-admin-template/
/materio-vuetify-vuejs-admin-template/demo-1/dashboard-analytics
/materio-vuetify-vuejs-admin-template/demo-1/
/sneat-bootstrap-vue-admin-template/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)