$re = '/\/(?<directory_name>(?<template_name>[\w]+)[-\w]+)\//m';
$str = '/materio-vuetify-vuejs-admin-template/
/materio-vuetify-vuejs-admin-template/demo-1/dashboard-analytics
/materio-vuetify-vuejs-admin-template/demo-1/
/sneat-bootstrap-vue-admin-template/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);