// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/(?<directory_name>(?<template_name>[\w]+)[-\w]+)\/").unwrap();
let string = "/materio-vuetify-vuejs-admin-template/
/materio-vuetify-vuejs-admin-template/demo-1/dashboard-analytics
/materio-vuetify-vuejs-admin-template/demo-1/
/sneat-bootstrap-vue-admin-template/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}