import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/(?<directory_name>(?<template_name>[\\w]+)[-\\w]+)\\/";
final String string = "/materio-vuetify-vuejs-admin-template/\n"
+ "/materio-vuetify-vuejs-admin-template/demo-1/dashboard-analytics\n"
+ "/materio-vuetify-vuejs-admin-template/demo-1/\n"
+ "/sneat-bootstrap-vue-admin-template/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}