package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/(?<directory_name>(?<template_name>[\w]+)[-\w]+)\/`)
var str = `/materio-vuetify-vuejs-admin-template/
/materio-vuetify-vuejs-admin-template/demo-1/dashboard-analytics
/materio-vuetify-vuejs-admin-template/demo-1/
/sneat-bootstrap-vue-admin-template/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}