import Foundation
let pattern = #"(?i)(?<=^|.)returned to a\.r\.e\. for (?=.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
returned to A.R.E. for
Returned to A.R.E. for
RETURNED to A.R.E. for
RETURNED TO A.R.E. FOR
RETURNED to A.R.E. for A
A RETURNED to A.R.E. for
TEXTRETURNED to A.R.E. for TEXT
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)