use strict;
my $str = 'returned to A.R.E. for
Returned to A.R.E. for
RETURNED to A.R.E. for
RETURNED TO A.R.E. FOR
RETURNED to A.R.E. for A
A RETURNED to A.R.E. for
TEXTRETURNED to A.R.E. for TEXT
';
my $regex = qr/(?i)(?<=^|.)returned to a\.r\.e\. for (?=.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}