#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(?<=^|.)returned to a\.r\.e\. for (?=.*)"
Local $sString = "returned to A.R.E. for " & @CRLF & _
"Returned to A.R.E. for " & @CRLF & _
"RETURNED to A.R.E. for " & @CRLF & _
"RETURNED TO A.R.E. FOR " & @CRLF & _
"RETURNED to A.R.E. for A" & @CRLF & _
"A RETURNED to A.R.E. for " & @CRLF & _
"TEXTRETURNED to A.R.E. for TEXT" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")