$re = '/(?i)(?<=^|.)returned to a\.r\.e\. for (?=.*)/m';
$str = 'returned to A.R.E. for
Returned to A.R.E. for
RETURNED to A.R.E. for
RETURNED TO A.R.E. FOR
RETURNED to A.R.E. for A
A RETURNED to A.R.E. for
TEXTRETURNED to A.R.E. for TEXT
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);