using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?<=^|.)returned to a\.r\.e\. for (?=.*)";
string input = @"returned to A.R.E. for
Returned to A.R.E. for
RETURNED to A.R.E. for
RETURNED TO A.R.E. FOR
RETURNED to A.R.E. for A
A RETURNED to A.R.E. for
TEXTRETURNED to A.R.E. for TEXT
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}