$re = '/^(?:https?:\/\/)?([-\w.]+\.[\w]+){1}(\/[\/\d\w\.\-\?\+\&\#\=\~]*)?$/i';
$str = 'https://www.asd.google.com/search?q=some+text¶m=3#dfsdf';
$subst = "Domein: $1\nURI: $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;