# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:https?:\\/\\/)?([-\w.]+\.[\w]+){1}(\\/[\\/\d\w\.\-\?\+\&\#\=\~]*)?$/Domein: $1\nURI: $2/gi;t' <<< "https://www.asd.google.com/search?q=some+text¶m=3#dfsdf"