import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?([-\\w.]+\\.[\\w]+){1}(\\/[\\/\\d\\w\\.\\-\\?\\+\\&\\#\\=\\~]*)?$";
final String string = "https://www.asd.google.com/search?q=some+text¶m=3#dfsdf";
final String subst = "Domein: $1\\nURI: $2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}