const regex = /^(?:https?:\/\/)?([-\w.]+\.[\w]+){1}(\/[\/\d\w\.\-\?\+\&\#\=\~]*)?$/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/)?([-\\w.]+\\.[\\w]+){1}(\\\/[\\\/\\d\\w\\.\\-\\?\\+\\&\\#\\=\\~]*)?$', 'gi')
const str = `https://www.asd.google.com/search?q=some+text¶m=3#dfsdf`;
const subst = `Domein: $1\nURI: $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);