use strict;
my $str = 'https://www.asd.google.com/search?q=some+text¶m=3#dfsdf';
my $regex = qr/^(?:https?:\/\/)?([-\w.]+\.[\w]+){1}(\/[\/\d\w\.\-\?\+\&\#\=\~]*)?$/ip;
my $subst = 'Domein: $1\\nURI: $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";