// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*import.*").unwrap();
let string = "import backoff
from service.camera_simple.ffmpeg_dash_loop import rtsp_to_dash_loop
from share.settings.settings import Settings
from share.types.camera import Camera
from share.utils.adeck_logging.logging_subprocess import log_process_output
from share.utils.retry import on_backoff
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}